srpm problem

Alex Kramarov alex at incredimail.com
Fri May 17 17:01:38 BST 2002


although while running make, make install on the patched source produces
good results,
running rpm -ba ipvsadm.spec fails completely :

error: File /usr/src/redhat/SOURCES/ipvsadm-1.20.tar.gz: No such file or
directory

and rpm -ta on the patched tar file produces the following errors :

[root at rene root]# rpm -ta ipvsadm-1.20.tar.gz
[snip]
install -m 0755 ipvsadm /var/tmp/ipvsadm-1.20-root/sbin
install -m 0755 ipvsadm-save /var/tmp/ipvsadm-1.20-root/sbin
install -m 0755 ipvsadm-restore /var/tmp/ipvsadm-1.20-root/sbin
[ -d /var/tmp/ipvsadm-1.20-root//usr/share/man/man8 ] || mkdir -p
/var/tmp/ipvsadm-1.20-root//usr/share/man/man8
install -m 0644 ipvsadm.8 /var/tmp/ipvsadm-1.20-root//usr/share/man/man8
install -m 0644 ipvsadm-save.8
/var/tmp/ipvsadm-1.20-root//usr/share/man/man8
install -m 0644 ipvsadm-restore.8
/var/tmp/ipvsadm-1.20-root//usr/share/man/man8
if [ -d /var/tmp/ipvsadm-1.20-root/etc/init.d ]; then \
          install -m 0755 ipvsadm.sh
/var/tmp/ipvsadm-1.20-root/etc/init.d/ipvsadm; \
        fi
if [ -d /var/tmp/ipvsadm-1.20-root/etc/sysconfig ]; then \
          install -m 0644 ipvsadm.sysconfig
/var/tmp/ipvsadm-1.20-root/etc/sysconfig/ipvsadm; \
        fi
+ /usr/lib/rpm/brp-compress
+ /usr/lib/rpm/brp-strip
+ /usr/lib/rpm/brp-strip-comment-note
Processing files: ipvsadm-1.20-6
error: File not found: /var/tmp/ipvsadm-1.20-root/etc/rc.d/init.d/ipvsadm
Executing(%doc): /bin/sh -e /var/tmp/rpm-tmp.96772
+ umask 022
+ cd /usr/src/redhat/BUILD
+ cd ipvsadm
+ DOCDIR=/var/tmp/ipvsadm-1.20-root/usr/doc/ipvsadm-1.20
+ export DOCDIR
+ rm -rf /var/tmp/ipvsadm-1.20-root/usr/doc/ipvsadm-1.20
+ /bin/mkdir -p /var/tmp/ipvsadm-1.20-root/usr/doc/ipvsadm-1.20
+ cp -pr README /var/tmp/ipvsadm-1.20-root/usr/doc/ipvsadm-1.20
+ exit 0
Provides: ipvsadm-1.20
PreReq: /bin/sh /bin/sh
Requires(interp): /bin/sh /bin/sh
Requires(post): /bin/sh
Requires(preun): /bin/sh
Conflicts: piranha <= 0.4.14


RPM build errors:
    File not found: /var/tmp/ipvsadm-1.20-root/etc/rc.d/init.d/ipvsadm






----- Original Message -----
From: "Horms" <horms at verge.net.au>
To: <lvs-users at LinuxVirtualServer.org>
Sent: Friday, May 17, 2002 3:42 AM
Subject: Re: srpm problem


> On Tue, May 14, 2002 at 07:43:52PM +0200, Alex Kramarov wrote:
> > Hi.
> >
> > I just installed lvs director, and would like to report the following
problem :
> >
> > using the ipvsadm-1.20-6.src.rpm, i ran :
> >
> > rpm --rebuild ipvsadm-1.20-6.src.rpm
> > rpm -i <the resulting i386.rpm>
> >
> > it installs and works fine
> >
> > running /etc/init.d/ipvsadm save - results in no response.
> >
> > after looking at the code, i saw that /etc/init.d/ipvsadm expects
> > /etc/sysconfig/ipvsadm file to exist. it exits if the file does not
> > exist. the rpm does not create the file = problem.
>
> Ouch, that sounds a bit broken to me.  I have attached a patch with
> resolves this and some other minor RPM related problems.






More information about the lvs-users mailing list