newbie-problems

Joseph Mack mack.joseph at epa.gov
Fri May 24 12:22:28 BST 2002


Arshad Khan wrote:
> 
> I ran the configure script with nat-2nic-2networks. Because the director
> already had an IP at eth0 it produced error that eth0 already had VIP set up
> etc. 

the configure script sets these up for you. The VIP and the DIP are secondary
IPs so that they can be moved to another machine on director failover.
I haven't clearly pointed this out in the HOWTOs. I've just put a note
in the next versions

So i removed the IP from /etc/sysconfig/networking-scripts/ifcfg-eth0
> and rebooted. Then it ran fine except for one that I havent set variable
> $router_forwards. 

This takes a bit of figuring out I'll admit. If you don't have it set then
you just miss out on a redundant test.

Nevertheless, it produced rc.lvs-nat amongst others. When
> I ran rc.lvs.net. It produces errors of the type:
> 
> error not a server not a director
> I am not a server
> I am not a director

the host can't find its name/IP in the conf file. Are the names/IPs
the host uses, the same as in the conf file?

You can ignore any other errors till you fix this problem.

Joe


-- 
Joseph Mack PhD, Senior Systems Engineer, Lockheed Martin
contractor to the National Environmental Supercomputer Center, 
mailto:mack.joseph at epa.gov ph# 919-541-0007, RTP, NC, USA




More information about the lvs-users mailing list