Help with NAT

Ramon Kagan rkagan at YorkU.CA
Wed May 29 15:05:18 BST 2002


HI,

I was testing NAT between two Linux boxes on the same subnet. (1 NIC
director).  I got this working fine using the mini-howto and other docs on
the website with little trouble.

I then continued to setup a Solaris 8 machine to have the
defaultrouter/gateway set to the director.  I made no changes to the
director since it was working fine with the other box.  Other than the
Solaris/Linux real server change the ip's are now on different subnets.
The director is on subnet 202 and the real server subnet 236.  I tried
running "ipchains -A forward -s RIP(subst. of course) -j MASQ" on the
director but got "protocol not found."  I continued to use "iptables -t
nat -A POSTROUTING -s RIP -j MASQUERADE" and that command worked fine.
Nonetheless, the realserver is still unable to ping outside nor the
defaultrouter/gateway itself.

Any help would be much appreciated.

Ramon Kagan
York University, Computing and Network Services
Unix Team -  Intermediate System Administrator
(416)736-2100 #20263
rkagan at yorku.ca





More information about the lvs-users mailing list