[lvs-users] ipsec + lvs-nat not working

Sebastien COUPPEY sebastien.couppey at zero9.it
Wed Oct 22 13:36:08 BST 2008


On Wed, Oct 22, 2008 at 04:52:38AM -0700, Joseph Mack NA3T wrote:
> On Wed, 22 Oct 2008, Sebastien COUPPEY wrote:
> 
> > We can see that packets arrive back on the director, are correctly
> > rewritten and sent back to the client 10.44.0.254. However the client
> > never receive the packet.
> 
> I didn't look at the dump, but will take your interpretation 
> of it. Is it possible for you to have problems with the 
> reduced MTU of the ipsec packets. Can you fetch a small web 
> page from the realserver, or run a service with small 
> packets, eg telnet? If you haven't handled that already, 
> lookup the sections in the HOWTO that have MTU in the 
> section heading.

that a telnet. So the packets is very small. But I already tried the
fix MSS and tried to force also the MTU to 1400. It didn't change anything.


> 
> > I was wondering if the "brownfield" patch
> 
> don't know (but you only have one NIC?)

No 
eth0+eth3=bond0 = private network
eth2 = public IP interface.

Thanks




More information about the lvs-users mailing list