[lvs-users] Orphaned VIPs/real IPs

Timo Schoeler timo.schoeler at riscworks.net
Mon Jun 29 13:19:50 BST 2009


Hi list,

I got a weird problem running heartbeat-ldirectord-2.1.4-4.1 on a CentOS 
5.3 machine. I keep getting those error messages in ldirectord's log file:

[Mon Jun 29 11:39:12 2009|ldirectord|31139] system(/sbin/ipvsadm -a -t 
10.0.3.1:9000 -r 10.1.3.1:9000 -m -w 1) failed:
[Mon Jun 29 11:46:05 2009|ldirectord|5647] system(/sbin/ipvsadm -a -t 
10.0.3.1:9000 -r 10.1.3.2:9000 -m -w 1) failed:
[Mon Jun 29 11:49:35 2009|ldirectord|5647] system(/sbin/ipvsadm -a -t 
10.0.3.1:9000 -r 10.2.3.1:9000 -m -w 1) failed:
[Mon Jun 29 11:58:52 2009|ldirectord|5647] system(/sbin/ipvsadm -a -t 
10.0.3.1:9000 -r 10.2.3.1:9000 -m -w 1) failed:
[Mon Jun 29 13:18:44 2009|ldirectord|31139] system(/sbin/ipvsadm -a -t 
10.0.3.1:9000 -r 10.2.3.2:9000 -m -w 1) failed:
[Mon Jun 29 13:27:57 2009|ldirectord|5647] system(/sbin/ipvsadm -a -t 
10.0.3.1:9000 -r 10.2.3.2:9000 -m -w 1) failed:
[Mon Jun 29 13:38:48 2009|ldirectord|31139] system(/sbin/ipvsadm -a -t 
10.0.3.1:9000 -r 10.2.3.2:9000 -m -w 1) failed:
[Mon Jun 29 14:03:10 2009|ldirectord|31139] system(/sbin/ipvsadm -a -t 
10.0.3.1:9000 -r 10.2.3.2:9000 -m -w 1) failed:

Most interestingly, the 10.0.3.1:9000 <-> 10.2.3.2:9000 combination was 
first commented out in ldirectord.cf *months* ago (with following 
automatic restart of ldirectord.cf because we have autoreload=yes set) 
because the server does not run any more. Then I deleted the lines in 
the config file. In the meanwhile, the load balancer runs on another 
host (we have a four node IPVS setup, using heartbeat v2), and even 
there the problem remains.

Heartbeat's CIB does *not* contain the 10.0.3.1, neither does 
ldiretord.cf. I just don't know where it comes from, neither how to get 
rid of it. Any ideas?

Thanks & best regards,

Timo




More information about the lvs-users mailing list