[lvs-users] Trouble getting first LVS setup working

Chris St. Pierre stpierre at NebrWesleyan.edu
Fri Mar 20 19:37:09 GMT 2009


I'm playing with LVS to try and get a working test setup going, and
I'm running into some problems.  I've got three VMs -- two "real"
servers, one LVS router.  Everything appears to start up correctly,
'ipvsadm -L' looks like I think it should, but the routing from the
VIP to the real servers just plain isn't happening.  Network
connectivity between the router and real servers works fine, but I
can't even connect to the VIP on port 80.

Following Redhat's documentation, I've tried both the iptables
PREROUTING and the arptables methods, but neither has worked.

I'm sure I've made a silly mistake, but I can't for the life of me
figure it out.  And LVS's logging is so quiet that I'm not getting
much; all appears to be working according to the logs.

Thanks for your help!

##### lvs.cf #####

service = lvs
primary = 10.9.3.3
heartbeat = 1 
heartbeat_port = 1050
keepalive = 6 
deadtime = 18 
reservation_conflict_action = preempt
debug_level = NONE

network = direct

virtual server1 {
         address = 10.9.3.6 eth0:1
         vip_nmask = 255.255.0.0
         fwmark = 100
         active = 1
         load_monitor = rup
         timeout = 5
         reentry = 10
         port = http
         send = "GET / HTTP/1.0\r\n\r\n"
         expect = "HTTP"
         protocol = tcp

         server Real1 {
                 address = 10.9.3.1
                 active = 1
                 weight = 1
         }

         server Real2 {
                 address = 10.9.3.2
                 active = 1
                 weight = 1
         }
}

Chris St. Pierre
Unix Systems Administrator
Nebraska Wesleyan University




More information about the lvs-users mailing list