[lvs-users] LVS and stale connections

Fabio Coatti cova at ferrara.linux.it
Tue Mar 31 13:08:09 BST 2009


Hi all, 
we are using ipvs since years on several production servers and it works just 
fine, but now we are facing a weird problem. 
I'm unable to find a solution browsing around, so I'm asking for some hints 
here.
Basically, the scenario is the following:
5 servers (RIP), balanced with ipvs on linux 2.6.23, DR is used.
All works just fine, but if for some reasons the real servers freezes and need 
reboot, ipvs keeps as "alive" all the connections so the balancing is not 
correctly done. 
say, after reboot a couple (out of five) of servers shows with ipvsadm -L more 
than 1000 connections (and all of those are fake, as the Rservers have been 
rebooted) and ipvs doesn't pass any new connection until the count lowers 
enough and only 3 servers are actually working.
To fix this, I've tried to remove from ipvs real servers, virtual IP, I've also 
zeroed the tables but no success: when I reconfigure it all the RIP shows that 
all the connections are still there. The situation improves only after the 
connection timeout expires (usually 8 hours). If I lower this timeout, only 
new connection expires in a shorter time, so this is not a good solution. We 
need to keep high timeouts for several reasons (say, databases).
Is there any way to clear this counter (syscalls, proc, whatever) so I can 
recover a correct behaviour of the balancer without booting the machine? I can 
figure out that it's a situation that ipvs can't handle automtically, but a way 
to clear tables should be useful.

If course I'm available for further details.

Many thanks in advance for any answer.







More information about the lvs-users mailing list