[lvs-users] Two box lvs with UltrMonkey LO problem

Cyrus cyrus at gravytrain.co.uk
Fri Apr 2 20:24:33 BST 2010


Hello All,

I am setting up a two node HA/Load-balancing solution using LVS/Ultramonkey
according to this guide:
http://www.ultramonkey.org/3/topologies/sl-ha-lb-eg.html

I have the issue that heartbeat does not automatically start the ldirectord,
I start it myself and sart the master on the master node but the VIP
(174.121.60.28) is not visible outside of the master server.

Ifconfig shows this:

eth0      Link encap:Ethernet  HWaddr 00:26:B9:7C:DF:0B
          inet addr:174.121.60.26  Bcast:174.121.60.31  Mask:255.255.255.248
          inet6 addr: fe80::226:b9ff:fe7c:df0b/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:16578 errors:0 dropped:0 overruns:0 frame:0
          TX packets:19160 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:1946167 (1.8 MiB)  TX bytes:3890358 (3.7 MiB)
          Interrupt:169 Memory:da000000-da012800

eth0:1    Link encap:Ethernet  HWaddr 00:26:B9:7C:DF:0B
          inet addr:174.121.60.28  Bcast:174.121.60.31  Mask:255.255.255.248
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          Interrupt:169 Memory:da000000-da012800

lo        Link encap:Local Loopback
          inet addr:127.0.0.1  Mask:255.0.0.0
          inet6 addr: ::1/128 Scope:Host
          UP LOOPBACK RUNNING  MTU:16436  Metric:1
          RX packets:1114 errors:0 dropped:0 overruns:0 frame:0
          TX packets:1114 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0
          RX bytes:89934 (87.8 KiB)  TX bytes:89934 (87.8 KiB)

lo:0      Link encap:Local Loopback
          inet addr:174.121.60.28  Mask:255.255.255.255
          UP LOOPBACK RUNNING  MTU:16436  Metric:1


I would appreciate if anyone could tell me what could be wrong? I cannot
find anything in the logs.

Kind regards,

Cyrus





More information about the lvs-users mailing list