[lvs-users] LVS director suddenly stops forwarding connections.

Terry Inzauro tinzauro at ha-solutions.net
Tue Apr 6 22:43:51 BST 2010


List,

I've got a LVS director running on a pair of clustered (with corosync/pacemaker) compaq dl380's.  Until today, all seemed to
be working great.  Now, the active director periodically stops forwarding connections to the realservers.

If I migrate the ldirectord to the other node, forwarding resumes.

<output from ipvsadm right after issues begin>

root at valerie:~# ipvsadm -ln --stats
IP Virtual Server version 1.2.1 (size=4096)
Prot LocalAddress:Port               Conns   InPkts  OutPkts  InBytes OutBytes
  -> RemoteAddress:Port
TCP  55.11.212.110:636                   0        0        0        0        0
  -> 10.0.10.102:636                     0        0        0        0        0
  -> 10.0.10.104:636                     0        0        0        0        0
TCP  55.11.212.110:587                   6       53        0     6162        0
  -> 10.0.10.104:587                     5       36        0     3187        0
  -> 10.0.10.101:587                     1       17        0     2975        0
TCP  55.11.212.110:80                   21      670        0    83495        0
  -> 10.0.10.100:80                     10      394        0    35685        0
  -> 10.0.10.105:80                     11      276        0    47810        0
UDP  55.11.212.110:53                   59       59        0     4918        0
  -> 10.0.10.102:53                     31       31        0     2599        0
  -> 10.0.10.104:53                     28       28        0     2319        0
TCP  55.11.212.110:25                   15      193        0    42588        0
  -> 10.0.10.101:25                      8       95        0    23619        0
  -> 10.0.10.104:25                      7       98        0    18969        0
TCP  55.11.212.110:993                  16      756        0    74020        0
  -> 10.0.10.101:993                     6      375        0    36887        0
  -> 10.0.10.104:993                    10      381        0    37133        0
TCP  55.11.212.110:443                  39      441        0    83813        0
  -> 10.0.10.100:443                    21      246        0    45614        0
  -> 10.0.10.105:443                    18      195        0    38199        0
TCP  55.11.212.110:389                   0        0        0        0        0
  -> 10.0.10.102:389                     0        0        0        0        0
  -> 10.0.10.104:389                     0        0        0        0        0

root at valerie:~# ipvsadm -ln
IP Virtual Server version 1.2.1 (size=4096)
Prot LocalAddress:Port Scheduler Flags
  -> RemoteAddress:Port           Forward Weight ActiveConn InActConn
TCP  72.22.215.110:636 wlc
  -> 10.0.10.102:636              Route   1      0          0
  -> 10.0.10.104:636              Route   1      0          0
TCP  72.22.215.110:587 wlc
  -> 10.0.10.104:587              Route   1      0          0
  -> 10.0.10.101:587              Route   1      0          0
TCP  72.22.215.110:80 wlc
  -> 10.0.10.100:80               Route   1      0          0
  -> 10.0.10.105:80               Route   1      0          0
UDP  72.22.215.110:53 wlc
  -> 10.0.10.102:53               Route   1      0          4
  -> 10.0.10.104:53               Route   1      0          3
TCP  72.22.215.110:25 wlc
  -> 10.0.10.101:25               Route   1      0          0
  -> 10.0.10.104:25               Route   1      0          0
TCP  72.22.215.110:993 wlc
  -> 10.0.10.101:993              Route   1      5          0
  -> 10.0.10.104:993              Route   1      6          0
TCP  72.22.215.110:443 wlc persistent 600
  -> 10.0.10.100:443              Route   1      0          0
  -> 10.0.10.105:443              Route   1      0          0
TCP  72.22.215.110:389 wlc
  -> 10.0.10.102:389              Route   1      0          0
  -> 10.0.10.104:389              Route   1      0          0

</output from ipvsadm right after issues begin>


I am using debian lenny with packages from the backports repo

ldirectord/lenny uptodate 1:1.0.2+hg1712-1~bpo50+1
pacemaker/lenny uptodate 1.0.8-3~bpo50+1
corosync/lenny uptodate 1.2.0-3~bpo50+1
libcorosync4/lenny uptodate 1.2.0-3~bpo50+1

Any ideas?




More information about the lvs-users mailing list