[lvs-users] ipvs not doing any link balancing

Malcolm Turnbull malcolm at loadbalancer.org
Thu Aug 26 12:56:37 BST 2010


Siva,

Um... What made you think LVS can do link balancing?
Its for server load balancing.


On 26 August 2010 06:46, Sivaraman Kannan <k.sivaraman at gmail.com> wrote:
>
> Hi guys
>    I have a setup where I have three interfaces on my linux box, one is a
> LAN interface and two are connected to the internet and I want to do link
> balancing of all packets coming from the LAN onto the two WAN interfaces.
>
> I have configured ipvs to do the link balancing (scheduling is weighted
> round-robin) using the following command for each WAN interface:
>
> ipvsadm -a -f <fwmark> -r wan_real_server_ip -z wan_interface -w weight -j
>
> Right now, the behavior is that LVS does not do any link balancing, but only
> sends it out of one interface (i think the first interface that came up).
> ipvsadm -lnc shows a whole bunch of connections in SYN_RECV state...anything
> which came in on the other interface never gets a reply.
>
> If I specify the real server IP as the WAN gateway instead of the interface
> IP itself, it works but I really need this scenario to work. Any
> suggestions? Do you need more information? Please let me know. Thanks!
>
> regards
> Siva.
> _______________________________________________
> Please read the documentation before posting - it's available at:
> http://www.linuxvirtualserver.org/
>
> LinuxVirtualServer.org mailing list - lvs-users at LinuxVirtualServer.org
> Send requests to lvs-users-request at LinuxVirtualServer.org
> or go to http://lists.graemef.net/mailman/listinfo/lvs-users



--
Regards,

Malcolm Turnbull.

Loadbalancer.org Ltd.
Phone: +44 (0)870 443 8779
http://www.loadbalancer.org/




More information about the lvs-users mailing list