[lvs-users] Fwd: LVS + Piranha + Direct Routing + iptables Problem

Anil Pillai rcamphor at gmail.com
Tue Jan 5 05:03:27 GMT 2010


 Hi,

I was able to implement LVS with Direct Routing (iptables).
I am facing a problem while using the iptables which requires

iptables enrty on Real servers like this (iptables –t nat –A PREROUTING –p
tcp –d <VIP> --dport <port> -j REDIRECT).



Below is a brief on the setup:



I have 3 servers Apache installed on all three servers (Port 80).



Server 1 (10.50.57.22)  -> 10.50.57.55 (VIP) -> running “Pulse”

Server 2 (10.50.57.40)

Server 3 (10.50.57.48)



I have configured LVS on port 80.  Added the below iptables entry on
10.50.57.40 & 10.50.57.48

iptables –t nat –A PREROUTING –p tcp –d 10.50.57.55 --dport 80 -j REDIRECT



With the above setup everything works fine. Even Apache on Server 1 (Which
has the VIP) get the request as part of Load sharing.



But if I add the iptables entry in Server 1 (10.50.57.22), Requests are
received only on the Apache installed this host.



The reason for doing this is to implement redundancy. Like in my case I have
implemented the redundant setup on Server 2 (10.50.57.40) and once the
“pulse” is stopped on Server 1(10.50.57.22), “pulse” is automatically
started on Server 2 (10.50.57.40) which acquired the VIP (10.50.57.55). But
since iptables is already active with the above entry all the requests are
going to the Apache of same host (10.50.57.40).



Does anyone faced similar issue ?



More information about the lvs-users mailing list