[lvs-users] [Keepalived-devel] Keepalived communication with kernel failing after some time

Graeme Fowler graeme at graemef.net
Wed Nov 9 14:58:52 GMT 2011


[copying in the LVS users list]

On Wed, 2011-11-09 at 12:04 -0200, Rodrigo Severo wrote:
> I have been using keepalived for some years now.
> 
> For some time now keepalived has started to fail when updating VS on
> the kernel. This kind of thing happens after some time where
> keepalived is working perfectly, i.e., failed servers been succesfully
> removed and returned servers successfully added to VSs. Just after
> keepalived is started everything works fine. After some time it starts
> to fail to update the VSs on the kernel.
> 
> To make it work again I just have to restart keepalived.
> 
> The error message I get on these failures are like:
> 
> [Keepalived_healthcheckers] IPVS: Invalid operation.  Possibly wrong
> module version, address not unicast, ...
> 
> 
> It's important to observe that the same exact operation that works
> fine just after keepalived is started will fail with the above error
> after some time (one or two hours) so the suggestions on the error
> message - wrong module version, wrong kind of address - can be safely
> discarded as causes of the problem.
> 
> I'm using Gentoo with kernel 3.0.6 and keepalived 1.2.2.
> 
> Any suggestions on how I can further debug this issue?

Yes. Please grab the log lines which indicate keepalived starting, doing
stuff to servers, then failing to do stuff to servers and send it to
lvs-users at linuxvirtualserver.org. I think we need to see timing, the
number of operations done and so on.

Your kernel is "out there" some way ahead of large numbers of the rest
of the world who lag behind on the 2.6.x branch. I suspect something
isn't quite right in the IPVS code in 3.0.x but I couldn't say what it
is.

Graeme





More information about the lvs-users mailing list