[lvs-users] extremely slow (10kb/s) LVS NAT on new RHEL 6 ... solved

Alois Treindl alois at astro.ch
Sat Nov 26 21:49:28 GMT 2011


I read the documentation again, and took this sentence to heart:

7.4. ipvsadm gives wierd erroneous output

Symptom: you get inpropriate characters, numbers for IPs, ports, 
services in the output of ipvsadm

Problem: your ipvsadm doesn't match the version of ip_vs. (You may have 
forgotten to compile the new version of ipvsadm after rebooting the 
computer following loading the LVS-patched kernel and you're using an 
old ipvsadm).

Solution: get the ipvsadm that matches your ip_vs.

I had:
kernel:  2.6.32-131.17.1.el6.x86_64 (from Redhat)
ipvsadm-1.25-9.el6.x86_64  from Centos 6

But the CentOS kernel in the same repository as ipvsadm is
kernel-2.6.32-71.el6.x86_64.rpm

on RHEL I have this older kernel of the same generation:
2.6.32-71.29.1.el6.x86_64

When I rebooted with it, the LVS worked!!!!!

Thanks for the help, Joseph.
It encouraged me that you responded, and made me read the manual again.




More information about the lvs-users mailing list