[lvs-users] Simple LVs scenario (all nodes in same subnet)

Javi Legido javi at legido.com
Wed Jun 20 13:17:42 BST 2012


 I'm playing with LVS, but no way to redirect HTTP request to real
   servers (details on http://pastebin.com/LUFRefnq).
   Some TCP 80 packets arrives to real servers, but looks like replies not.
   Any simple example of LVS?
   Should I 'echo 1 > /proc/sys/net/ipv4/ip_forward' in any server?
   Thanks
   Details:
       www.dev.jj.com is an alias of balancer-1.dev.jj.com 10.0.0.15
       ########################################################################
       $ sudo ipvsadm
       IP Virtual Server version 1.2.1 (size=4096)
       Prot LocalAddress:Port Scheduler Flags
         -> RemoteAddress:Port           Forward Weight ActiveConn InActConn
       TCP  balancer-1.dev.jj.com:www rr
         -> test-4.dev.jj.com:www        Route   1      0          0

- Ignored:
         -> test-5.dev.jj.com:www        Route   1      0          0

       ########################################################################

       Client:

       $ wget -O - http://www.dev.jj.com
       --2012-06-20 13:13:02--  http://www.dev.jj.com/
       Resolving www.dev.jj.com... 10.0.0.15
       Connecting to www.dev.jj.com|10.0.0.15|:80...

       Balancer:

       $ sudo ipvsadm
       IP Virtual Server version 1.2.1 (size=4096)
       Prot LocalAddress:Port Scheduler Flags
         -> RemoteAddress:Port           Forward Weight ActiveConn InActConn
       TCP  balancer-1.dev.jj.com:www rr
         -> test-4.dev.jj.com:www        Route   1      0          0
         -> test-5.dev.jj.com:www        Route   1      0          1




More information about the lvs-users mailing list