[lvs-users] Problem setting up DNS servers over IPv6

Filipe Cifali cifali.filipe at gmail.com
Wed Jun 19 16:06:21 BST 2013

(turns out my previous MX problem was my fault, forgot to skip arp

So I'm setting up a new cluster, now for DNS service, and I'm running the
Heartbeat + LdirectorD to setup the IPVS,

Over IPv4 its working as expected, but over IPv6 I'm getting errors:

ResourceManager[14729]: 2013/06/18_19:01:51 ERROR: Return code 1 from
ResourceManager[14729]: 2013/06/18_19:01:51 CRIT: Giving up resources due
to failure of IPv6addr::2000:0010:0005:0000:0000:0000:0088:2/64/eth1

What I have tried:


Searching I found some posts saying Resource Manager was getting "::" as a
wrong argument.

Searching more I've found some other posts saying that IPv6 wasn't working
correctly but seems like the IPv6addr that's not working as when I run him:

# /etc/ha.d/resource.d/IPv6addr 2000:10:5::88:2/64/eth1 start
IPv6addr[18042]: ERROR:  Generic error
ERROR:  Generic error
# /etc/ha.d/resource.d/IPv6addr 2000:10:5:0:0:0:88:2/64/eth1 start
IPv6addr[18067]: ERROR:  Generic error
ERROR:  Generic error
# /etc/ha.d/resource.d/IPv6addr
2000:0010:0005:0000:0000:0000:0088:2/64/eth1 start
IPv6addr[18098]: ERROR:  Generic error
ERROR:  Generic error

(is this the right place to post this?)

[ ]'s

Filipe Cifali Stangler

More information about the lvs-users mailing list