[lvs-users] Kernel Panic when adding a service

Luc van Donkersgoed luc at codingdutchmen.com
Thu Oct 10 11:17:05 BST 2013


Dear list,

I've used IPVS with ldirectord on Ubuntu for a couple of years, never had much trouble. Recently, however, I've tried to setup a new HA Load Balancer cluster for DNS and I'm running into reproducable kernel panics. 

I've narrowed the panics down to the point where i run "sudo /sbin/ipvsadm -A -u 10.0.50.4:53" and a panic immediately occurs.

The last part of the stack track can be seen in this image: http://cl.ly/image/1K3P1Q0Y242t

My setup is a Virtual Machine (VMWare) running a clean install of Ubuntu 13.04, all updates installed, running kernel 3.8.0-31-generic.

I've installed no extra packages, except for heartbeat and ldirectord. 

Running ipvsadm -v produces the following result:
ipvsadm v1.26 2008/5/15 (compiled with popt and IPVS v1.2.1)

Running ldirectord -v produces the following result:
Linux Director v1.186-ha

I've tried googling, but could find no results for my specific scenario. Any help would be greatly appreciated.

Best regards,
Luc van Donkersgoed


More information about the lvs-users mailing list