[lvs-users] ipvsadm fix --ops option

Paul Zirnik paul at zirnik.de
Thu Jan 16 12:37:48 GMT 2014


Hi all,

i am new to LVS, but during my first learning steps i encountered
some issue where i got stuck because of strange error messages.
Attached are two "cosmetic" patches against ipvsadm-1.26, that
try to fix this.

1. ipvsadm-1.26-fix_options.diff

this patch fixes the error handling when option "-o" or "--ops" is used where
it is not allowed, like:

# ipvsadm -a -u 192.168.42.42:1234 -r 192.168.21.21:1234 -g -w 1 --ops
Illegal 'exact' option with the 'add-server' command

however i am not sure at what condition option "--pe" can be used,
looks like it is only valid for "-list" option

2. ipvsadm-1.26-fix_list.diff

this patch corrects the output of "pe" and "ops" option in "--list" output,
not only when "-p" (persistent) option was used or a special output format.

It would be nice if this could be reviewed and added to next release.

regards,
        Paul
-------------- next part --------------
A non-text attachment was scrubbed...
Name: ipvsadm-1.26-fix_options.diff
Type: text/x-patch
Size: 4335 bytes
Desc: not available
Url : http://lists.graemef.net/pipermail/lvs-users/attachments/20140116/42eeda05/attachment.bin 
-------------- next part --------------
A non-text attachment was scrubbed...
Name: ipvsadm-1.26-fix_list.diff
Type: text/x-patch
Size: 590 bytes
Desc: not available
Url : http://lists.graemef.net/pipermail/lvs-users/attachments/20140116/42eeda05/attachment-0001.bin 


More information about the lvs-users mailing list