[lvs-users] Problem with ldirectord Bug?

Ben Cabot ben at loadbalancer.org
Fri Jun 6 10:16:52 BST 2014


Julian,

Running cat /proc/net/ip_vs gives the correct output.

IP Virtual Server version 1.2.1 (size=4096)
Prot LocalAddress:Port Scheduler Flags
  -> RemoteAddress:Port Forward Weight ActiveConn InActConn
TCP  0A000148:0328 rr
  -> 0A00014A:0328      Masq    1      0          0
  -> 0A000149:0328      Masq    1      0          0

Regards


On 6 June 2014 08:16, Julian Anastasov <ja at ssi.bg> wrote:

>
>         Hello,
>
> On Thu, 5 Jun 2014, Ben Cabot wrote:
>
> > I've seen the same thing, It looks like ipvsadm is not displaying the
> > details from lvs correctly.
> > However looking at a packet capture you can see it is sending traffic to
> > all servers.
> >
> >
> > [root at ip-10-0-1-72]# ipvsadm -A -t 10.0.1.72:808 -s rr
> > [root at ip-10-0-1-72]# ipvsadm -a -t 10.0.1.72:808 -r 10.0.1.73:808 -m
> > [root at ip-10-0-1-72]# ipvsadm -Ln
> > IP Virtual Server version 1.2.1 (size=4096)
> > Prot LocalAddress:Port Scheduler Flags
> >   -> RemoteAddress:Port           Forward Weight ActiveConn InActConn
> > TCP  10.0.1.72:808 rr
> >   -> 10.0.1.73:808                Masq    1      0          0
> > [root at ip-10-0-1-72]# ipvsadm -a -t 10.0.1.72:808 -r 10.0.1.74:808 -m
> > [root at ip-10-0-1-72]# ipvsadm -Ln
> > IP Virtual Server version 1.2.1 (size=4096)
> > Prot LocalAddress:Port Scheduler Flags
> >   -> RemoteAddress:Port           Forward Weight ActiveConn InActConn
> > TCP  10.0.1.72:808 rr
> >   -> 10.0.1.73:808                Masq    1      0          0
>
>         Do you see the same with this command?:
> cat /proc/net/ip_vs
>
> > [root at ip-10-0-1-72]# ipvsadm -v
> > ipvsadm v1.26 2008/5/15 (compiled with popt and IPVS v1.2.1)
> >
> > This was using ec2 with amazons kernel 3.10.40-50.136.amzn1.i686.
> >
> >
> >
> > On 4 June 2014 10:38, Migue Martin <miguegt at hotmail.es> wrote:
> >
> > > Hi all.
> > >
> > > I'm having a problem with ldirectord that I can not solve, I comment my
> > > situation:
> > >
> > >
> > > The problem is in the ipvsadm only show a one real IP, when i
> configured
> > > two now, show  the ldirector.cf:
> > >
> > >
> > > root at ldap1:/home/mamartin# ipvsadm
> > > IP Virtual Server version 1.2.1 (size=4096)
> > > Prot LocalAddress:Port Scheduler Flags
> > >   -> RemoteAddress:Port           Forward Weight ActiveConn InActConn
> > > TCP  ldap-maqueta.cica.es:ldap wrr
> > >   -> ldap2.cica.es:ldap            Route   4      0 0
> > > TCP  [[fc00:1::3]]:ldap wrr
> > >   -> [[fc00:1::2]]:ldap Route   4      0 0
>
> Regards
>
> --
> Julian Anastasov <ja at ssi.bg>
>



-- 
LOADBALANCER.ORG LTD.
www.loadbalancer.org
support at loadbalancer.org


More information about the lvs-users mailing list