[lvs-users] Load Balancing SMTP with direct routing

Alexandre infos at opendoc.net
Thu Oct 16 13:02:36 BST 2014


Hello list, I will wish to implement an architecture of outgoing mail 
servers. We already have a SQL load balancer. Here is my plan. All ports 
are standard and LVS is configured with direct routing

1. Web server response directly to a client
2. Mysql server repose directly to a web server
3. Servers generate emails and push email to a load balancer on port 25
4. Mail servers send mails to different recipients.

                              INTERNET
                                 |
                             +------+
                             |ROUTER|
                             +------+
                                 |
                                 |
                                 |
                                 |
                                 |
                             +---+----+
Outbound mail server<-------|  LVS   |-----------> Web server
                             +---+----+
                                 |
                                 |
                                 |
                                 |
                                 |
                                 |
         +-----------------------+----------------------------------+
         |                                                          |
         |                                                          |
Servers that generate emails.                              Mysql Server



Here is my set :
--------------------------------------------------------------------------------
# ====================
# OUTBOUND MAIL SERVER
# ====================
virtual=10.0.0.102:25
         emailalert="admin at meteoconsult.fr"
         real=10.0.0.96:25 gate
         real=10.0.0.97:25 gate
         real=10.0.0.98:25 gate
         real=10.0.0.97:25 gate
         service=smtp
         scheduler=rr
         fallback=127.0.0.1:25 gate
         protocol=tcp
         checktype=negotiate
--------------------------------------------------------------------------------


On outbound mail server, I add in a rc.local :
--------------------------------------------------------------------------------
/bin/echo 1 > /proc/sys/net/ipv4/conf/eth0/arp_ignore
/bin/echo 2 > /proc/sys/net/ipv4/conf/eth0/arp_announce
/sbin/ifconfig lo:0 10.0.0.102 netmask 255.255.255.255 up
--------------------------------------------------------------------------------

However nothing works. When I make a test with telnet :
- through the load balancer:
---
telnet 10.0.0.102 25
Trying 10.0.0.102...
telnet: Unable to connect to remote host: Connection refused
---

- directly to the mail server :
---
telnet 10.0.0.96 25
Trying 10.0.0.96...
Connected to 10.0.0.96.
Escape character is '^]'.
220 XXXXXXXXXXXXXXXXXXXX ESMTP Exim 4.80 Thu, 16 Oct 2014 13:58:49 +0200
---

Do you have any idea? I'm a bit stuck.

Thank you to all.




More information about the lvs-users mailing list