[lvs-users] cannot start master/backup daemon Centos 7

Phillip Moore pdm at pobox.com
Tue Jun 26 22:26:06 BST 2018


Ok, well I figured this out. From 6 -> 7 the sync process names changed.
Turns out.. they were already running.

6 was [ipvs_syncmaster] and [ipvs_syncbackup]
7 is now [ipvs-m:0:0] and [ipvs-b:0:0]



On Tue, Jun 26, 2018 at 11:01 AM, Phillip Moore <pdm at pobox.com> wrote:

>
> Hi,
>
> We're trying to get IPVS working on Centos7 and running into something I
> didn't see on earlier versions. IPVS is working otherwise. It is able to
> load balance to backends and such but I cannot make the master/backup
> daemons start.
>
> I don't really have a lot to go on really and looking for suggested
> avenues of investigation. I did try deleting the ipv6 address off this vlan
> interface but it didn't help. (I read syncing only works with ipv4).
>
> # ipvsadm --start-daemon master --mcast-interface vlan1101 --syncid 1
> No such device or address
>
> # ip addr show dev vlan1101
> 9: vlan1101 at bond0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 9000 qdisc
> noqueue state UP qlen 1000
>     link/ether 00:0a:f7:bd:c7:04 brd ff:ff:ff:ff:ff:ff
>     inet 10.241.8.69/26 brd 10.241.8.127 scope global vlan1101
>        valid_lft forever preferred_lft forever
>     inet6 fe80::20a:f7ff:febd:c704/64 scope link
>        valid_lft forever preferred_lft forever
>
> # cat /etc/redhat-release
> CentOS Linux release 7.4.1708 (Core)
>
> # uname --r
> 3.10.0-862.3.2.el7.x86_64
>
> ipvsadm v1.27 2008/5/15 (compiled with popt and IPVS v1.2.1)
>
>
>


More information about the lvs-users mailing list